gemのバージョンアップ

2015/01/10 17:52 に 森山誠二郎 が投稿   [ 2015/01/10 20:05 に更新しました ]
ruby 1.8.7で、gemのバージョン1.3.5だったので、旧バージョンのALBのためにchef-clientをgem installしたためのメモ

gem update --systemで、gemのバージョンが2.4.5にあがり、つづいて以下を実行した
  gem install mixlib-shellout -v=1.4.0
  gem install chef -v=11.14.2
最新版は、1.8.7をサポートしなくなってるので古いバージョンを指定した
ところが、これをやると、mutexなんちゃらエラーでダメダメだった!
結局、gem update --system 1.3.7 というふうにバージョンを指定してgemのバージョンをさげた
Comments