linux mint 15にruby 1.8.7 インストール

2013/07/13 1:39 に 森山誠二郎 が投稿   [ 2013/10/25 22:03 に更新しました ]
linux mint 15は、ubuntu 13.04 ベース。gcc 4.7.3

centos 5で作成した ruby 1.8.7 (w/qtbindings)では、segmentation faultした。

事前に apt-get install libssl-dev zlib1g-dev
そうしないと、gem installの際にno such file to load --zlib エラーが出る
(参考:http://d.hatena.ne.jp/inouetakuya/20120320/1332243950)
configure CFLAGS="-O2 -fno-tre-dce -fno-optimize-sibling-calls" ... とする。そうしないと
gem install時にsegmentation faultする。
(参考:http://serverfault.com/questions/456640/segfault-in-timeout-rb-using-gem-with-ruby-enterprise-edition-ree-1-8-7 )

apt-get install libxslt1-dev libxml2-dev する前に gem install mechanizeしようとすると、nokigiri requires Ruby version>=1.9.2
のエラー
    nokogiri -v=1.5.5 mechanize -v=2.5.1を指定した
mechanizeのgem installにg++が必要なので、apt-get install g++

gem install qtbindingsのために、apt-get install cmake libgl1-mesa-dev libglu1-mesa-dev libxml2-dev libxslt-dev

KDE版では、KDEのQt(4.8.4)と上記qtbindingsのQt(4.8.0)のミスマッチにより、Cannot mix incompatible Qt libraryとなる。
結局、KDE版では、FreeBSDの時と同様、korundumを用いることにする。
必要な変更: (2013-10-26追記)
 ・apt-get install ruby-kde4
     これで、/usr/lib/ruby/1.8/KDE/korundum4.rb がインストールされる。
      ruby 1.9xのkorundum4.rbが存在するかはわからない。
      (KDEのqt4を使って gem install qtbindingsすれば、ruby 1.9x用のQt4rubyは作られる)

Comments