ruby2.4で、 json gem v1.8.3 をビルドできない問題

2017/10/22 7:42 に 森山誠二郎 が投稿
AWS上のAmazon Linuxにchef clientに入れてembedded/bin/rubyを使ってbundle installすると
An error occurred while installing json (1.8.3), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.3'` succeeds before bundling.
json gem v1.8.3 をビルドできない問題に回答が書かれていて、
解決策

1.8.5 で解決されたらしいので、 v1.8 ブランチを使えばOK。

gem 'json', github: 'flori/json', branch: 'v1.8'
Comments