Mac OSX 10.11 El CapitanでScilab 5.5.2を動かす対策

2016/01/11 6:10 に 森山誠二郎 が投稿   [ 2016/01/11 6:13 に更新しました ]
El Capitanにバージョンアップすると、以下のメッセージでScilabが動かなくなる。
This version of Scilab will probably fail on this system (10.11): Scilab requires 10.6.5 (Snow Leopard) or newer system.

ステップ1: java6 runtimeをダウンロード - Java for OS X 2015-001 から入れる
 http://newtips.co/st/questions/33215610/scilab-5-5-2-doesnt-work-on-mac-os-x-10-11.html
ステップ2: これだけだと以下のエラーで落ちる。
 dyld: Symbol not found: _double_general_add
Re: Scilab with Mac OSX El Capitan に従って、以下のファイルを削除する:
    /Volumes/scilab-5.5.2/scilab-5.5.2.app/Contents/MacOS/lib/thirdparty/libBLAS.dylib

これで、起動後Try anyway を選択すれば動く。
Comments