rubyzipについてのメモ

2015/01/26 19:06 に 森山誠二郎 が投稿   [ 2015/02/02 20:30 に更新しました ]
v1.0.0になったときに仕様がかわった(Zip::ZipFileがZip::Fileなど)。
0.9.9までの通りに動かすには、gem install zip-zipすればよい。従来(ruby1.8.7)通り、
require 'zip/zipfilesystem' すればよい。

自分のためのメモ: windowsマシーンで、rubyzip 1.1.4をインストールしたがzip-zipを入れ忘れていたため、require 'zip/zipfilesystem'がエラーとなり。あれぇ?っとなって変なことをしていた。一応ALTAにもGemfileを用意しているので
bundle installすること!
Comments