(MacPortsを使わない)インストール

2011/08/18 4:43 に 森山誠二郎 が投稿   [ 2011/08/18 8:19 に更新しました ]
1. MySQL

mysql2の最新版 mysql2-0.3.7をgem installしたところ、Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter`というCentOSの時と同じようなエラーが出る。ruby1.8.7はサポート外か?
との判断で、mysql2-0.2.10を入れ直す。

しかし、 今度は、Please install the mysql2 adapter: `gem install activerecord-mysql2-adapter` (dlopen(/Library/Ruby/Gems/1.8/gems/mysql2-0.2.10/lib/mysql2/mysql2.bundle, 9): Library not loaded: libmysqlclient.18.dylib (RuntimeError)というエラー。
googleの記事Ruby, Rails and MySQL 5.5 Oh my! を参考に、以下を実行したところ、見事クリア
sudo install_name_tool -change libmysqlclient.18.dylib /usr/local/mysql/lib/libmysqlclient.18.dylib /Library/Ruby/Gems/1.8/gems/mysql2-0.2.10/lib/mysql2/mysql2.bundle

蛇足: sqlite3のままだと、adminユーザがadminでなくなったり原因不明のエラーが発生した。
   OSX Lionではpostgresglが標準添付になっているのでこの際乗り換えまで考えたが、当面
   MySQLでいくことにする。
2. LTspice
 Wineを一緒にパックしてくれたもの(winebottled version of LTSPice)がLTSpice for Mac OSX
3. MacSpice http://www.macspice.com/Download.html
Comments