CentOS 6.4(64bit)で、IC615

2013/05/27 23:10 に 森山誠二郎 が投稿   [ 2013/06/11 2:06 に更新しました ]
注意:2012/6時点ではIC615は正式にはRHEL6をサポートしてなかった。
   参考:http://www.cadence.com/Community/forums/t/22820.aspx

1。iscape.shでインストールする際、yum install libXext.i686 libXtst.i686の必要があった
2。verilog-aを使用すると以下のようなエラーがずらずら
   /usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory

This error message shows up on the 64 bit systems where GCC/UPC multilib feature is enabled, and it indicates that 32 bit version of libc is not installed. There are two ways to correct this problem:

  1. Install 32 bit version of glibc (e.g. glibc-devel.i686 on Fedora, CentOS, ..)
  2. Disable 'multilib' build by supplying "--disable-multilib" switch on the compiler configuration command

ということなので、素直にglibc-devel.i686をyumインストールする

dbAccessは32 bit版だったので、yum install libXp.i686の必要があった(2013/6/11追記)

Comments