UbuntuにRuby、rubygems、Rails、Hobo、sqlite3をインストール

Post date: 2009/01/08 0:51:28

  1. Ruby -- apt-get install ruby
  2. rubygems -- apt-get install rubygemsでは古いバージョンがインストールされ
    1. しかもupdate --systemできないよう細工されているので、オリジナルをインストールする
    2. cd rubygems-1.x.x; ruby setup.rb
  3. Rails -- gem install rails
  4. Hobo -- mislav_will-paginateが必要なので
    1. gem sources -a http://gems.github.com
    2. gem install hobo
  5. sqlite3 -- libsqlite3-dev と ruby1.8-devとsqlite3-rubyが必要
    1. apt-get install ruby1.8-dev libsqlite3-dev sqlite3
    2. gem install sqlite3-ruby
  6. hobo 実行時にopensslが無いといわれるので
    1. apt-get install libopenssl-ruby
  7. hoboは、textileを使っているので
    1. gem install RedCloth